【服务器安全管理系统】【客户端】sshd服务升级后,疑似安装Agent导致无法远程

Jack发表于:2020年09月18日 00:44:17

适配版本


产品:服务器安全管理系统

版本:V7.2.0.8

平台:Linux

关键字

关键报错信息:远程服务器提示“Permission denied,Please try again"

问题描述

通过SSH远程登录服务器,安装完agent以后,未开启防护功能模块,ssh通过22端口无法远程登陆,重启SSH服务无效


报错信息


1、远程登陆报错

image.png

2、查看/var/log/secure安全日志文件报错,提示找不到pam_stack.so文件

image.png


问题原因分析


1、sshd服务进行过升级,导致/etc/pam.d/sshd文件内容变更

升级前文件内容:

image.png

升级后文件内容:

image.png

2、sshd升级后sshd文件调用了pam_stack.so认证模块,通过查看/var/log/secure日志发现在/lib64/security/目录下找不到此认证模块,导致远程失败

验证在/lib64/security/目录下是否有pam_stack.so认证模块

image.png


解决方案


将/etc/pam.d/sshd文件替换为未升级前文件,重启sshd服务。此方法可解决问题,但未成功定位到导致此问题发生的根本原因。

互联网资料链接:http://www.mamicode.com/info-detail-211017.html(sshd服务升级后出现问题解决方法参考资料)