【天眼】【分析平台-告警联动】SYSLOG配置外发白名单功能不生效

贺东东发表于:2021年06月23日 17:59:19更新于:2021年07月27日 10:56:49

1、问题描述

系统管理→联动管理→告警联动配置→SYSLOG配置→发送告警日志配置外发加白告警开关关闭,如下图所示,但是在syslog服务器依旧可以接收分析平台发送的白名单告警

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2、适用场景

适用于从308/408升级到309/409分析平台的情况

3、原因分析

从308/408(包含)之前的版本没有是否外发白名单告警的功能,如下图所示,在redis6380配置中查看没有”is_white\”:0的配置

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4、解决办法

由于309/409告警日志配置中过滤条件变更,从308/408升级到309/409分析平台需要重新配置告警日志发送过滤条件并保存成功才能使用,解决方法如下:

1)系统管理→联动管理→告警联动配置→SYSLOG配置

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2)观察一段时间确定syslog服务器是否还会接收到加白告警,如果还会继续收到加白告警,执行下面步骤确定配置是否正确

3)登录后台查询配置是否生效

1、ssh登录(默认所有地址均可登陆)用户名:admin密码:skyeye360_admin

输入diagnose命令,密码Qihoo-360-123!@#可以进入后台

2、连接redis6380

[root@skyeye ~]# redis-cli -p 6380

127.0.0.1:6380>

3、通过GET norths_syslog_alarm_conf命令查询告警日志的配置

image.png

\"is_white\": 0表示不外发加白告警,\"is_white\": 1表示外发加白告警